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In the EMNESS project, the objective is to update an existing lab at Grenoble INP —Esisar. This lab
deals with the development of secured loT applications teaching to Master 2 students. This labis a
part of a course named “loT Applications”. The goal of this lab is, for the students, to develop (from
scratch) a secured application collecting data from many devices. In the first version of the global
architecture, the main technologies are JEE-oriented. To modernize this architecture, the JEE server
isreplaced by a modern Quarkus server for backend and a Vue.js web interface for frontend. These
changes include an update of the development infrastructure available in the lab. The global
infrastructure is illustrated by Figure 1.
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Figure 1: Global infrastructure.

The Java development tools (Eclipse, Apache Maven, OpenJDK and Nexus Repository) are yet
installed at Grenoble INP —Esisar but they require to be updated. For JavaScript development, itis a
new installation and configuration for all tools (Node.js, npm and Visual Studio Code). A database
PostgreSQL is also installed to persist data because previously data are only stored in memory
database H2.

All the tools usedinthe global infrastructure are described in the following sections. For each tool, a
brief descriptionis done. For the updates, we give the old and the new versions installed while for
the new software only the installed version is given. We also detail the configuration and the
installation testing at Grenoble INP —Esisar.
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In this section, we presentthe update realized for the differenttools used to develop secured loT

2. Updates

applications. These tools are previously used at Grenoble INP —Esisar to develop Java applications,
including loT applications. An update of these different tools was required due to security concerns,
to new features, to requirements from others tools...

2.1. Open JDK: Runtime Environment

“Open JDK (Open Java Development Kit) is a free and open-source implementation of the Java
Platform, Standard Edition (Java SE)”1

Due to the prerequisites defined by Quarkus server and other tools, it required to update the Open
JDK version from 8to 11.

Old version T Newversion

OpenIDK OpenIDK 11
2019-03 2019-03

Download https://download.java.net/java/GA https://download.java.net/java/GA/
/imc8/03/binaries/jmc-8.2.1 linux- jdk11/13/GPL/openjdk-11.0.1 linux-
x64.tar.gz x64 bin.tar.gz

Installing OpenlJdk:

e Extract distribution archivein any directory: at Esisar in /usr/lib/jvm

Testinginstallation:

$ echo $JAVA HOME

/usr/lib/jvm/java-1.11.0-openjdk-amd64

$ java -version

openjdk version "11.0.15" 2022-04-19

OpenJDK Runtime Environment (build 11.0.15+10-post-Debian-1debl1ul)

Open]DK 64-Bit Server VM (build 11.0.15+10-post-Debian-1debllul, mixed
mode, sharing)

$ javac -version

javac 11.0.15

! https://en.wikipedia.org/wiki/OpenJDK
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“Apache Maven is a build automation tool primarily for Java projects, but it can also be used to
build and manage projects written in C#, Ruby, Scala and other languages.”” (Wikipedia)

2.2. Apache Maven: Build automation tool

Due to the prerequisites defined by Quarkus server, itrequired to update the Apache Maven version
from 3.5.3t0 3.8.6.

Old version T Newversion

Apache Maven 3.5.3 Apache Maven 3.8.6
2018-03-08 2022-06-06
BEGTECNEVERETS L | Java 7 Java7

Download https://archive.apache.org/dist/ma https://archive.apache.org/dist/mav
ven/maven-3/3.5.3/ en/maven-3/3.8.6/

Apache Maven website: https://maven.apache.org/index.html

Prerequisite for Apache Maven:

e Have a JDK installation on your system. Either set the JAVA_HOME environment variable
pointing to your JDK installation or have the java executable on your PATH.

Installing Apache Maven:

e Extract distribution archivein anydirectory: at Esisar in /opt/Maven

Testinginstallation:

$ mvn -version

Apache Maven 3.8.4 (9b656c72d54e5bacbed989b64718c159fe39b537)
Maven home: /opt/Maven/Maven-3.8.4

Java version: 11.0.15, vendor: Debian, runtime: /usr/lib/jvm/java-11-
openjdk-amdé64d

Default locale: fr_FR, platform encoding: UTF-8

0S name: "linux", version: "5.10.0-15-amd64", arch: "amd64", family: "unix"

2 https://en.wikipedia.org/wiki/Apache _Maven
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2.3. Sonatype Nexus Repository: Repository Management

“A repository manager is a dedicated server application designed to manage repositories of
binary components. The usage of a repository manager is considered an essential best practice
for any significant usage of Maven.”?

Due to security reasons, but also to benefit from new functionalities, it was re quired to update
the nexus server.

Old version T Newversion

320 3.1
2019-12-20 2022-08-27

Download https://download.sonatype.com/n  https://download.sonatype.com/ne
exus/3/nexus-3.20.0-04-unix.tar.gz  xus/3/nexus-3.41.1-01-unix.tar.gz
| type! About Nexus Reposlitory Manager
p ezl \ Version 3.41.0-01
u no lo| r Edition 0SS
| Cr:at Build Revision 7728b1ab4db0691cebb74c631d96b54881chf6313
hi b
- Build Timestamp 2022-07-26-1245-24539
feeellEl Copyright License
Learn

dheard copyright © 2008-present Sonatype, Inc.

All rights reserved. Includes the third-party code listed at hitp://links.sonatype.com/products/nexus
Ipro/attributions

Sonatype and Sonatype Nexus are frademarks of Sonatype, Inc.
Apache Maven is a trademark of the Apache Foundation.

1e Rise] M2Eclipse is a trademark of the Eclipse Foundation. b
All other trademarks are the property of their respective owners.

The HealthCheck plugin needs to access Scnatype Data Services to be fully functional.
Access to and use of the Sonatype Data Services is subject to Sonatype's separate terms of service for the
data services.

Figure 2: Screenshot of Nexus Repository Manager version at Grenoble INP - Esisar.

Installation orupgrades:

Accordingto the configuration: https://help.sonatype.com/repomanager3/installation-and-
upgrades

Configuration:

The Nexus Repository Manageris configured at Grenoble INP —Esisar with a set of remote
repositoriesinordertowork with Apache Maven, npm, Docker and Quarkus (Figure 3).

3 .

https://maven.apache.org/repository-
management.html#:~:text=A%20repository%20manager%20is%20a,any%20significant%20usage%200f%20Mav
en.
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Figure 3: Repositories' configuration.

Configuration of Apache Maven:

To use nexus repository manager with Apache Maven, itis required to configure Maven to
checkthe repository managerinstead of the default, built-in connection to the Central repository. To
do this, we added a mirror configuration in the settings.xml file.

<mirrors>
<mirror>
<id>default</id>
<url>http://nexus.esisar.grenoble-inp.fr:8081/repository/maven-public/</url>
<mirrorOf>*</mirrorOf>
</mirror>

</mirrors>

Figure 4: Mirror configuration in settings.xml file.
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24. Eclipse: Integrated Development Environment

“Eclipse is an Integrated Development Environment (IDE) used in computer programming. It
contains a base workspace and an extensible plug-in system for customizing the environment. It
is the second-most-popular IDE for Java development, and, until 2016, was the most popular.
Eclipse iswritten mostlyinJavaandits primary use is for developing Javaapplications, but it may
also be used to develop applications in other programming languages.”*

Eclipse is the tool used for all the Java development projects at Grenoble INP — Esisar, in
particular the course “Development of secured loT Applications”.

 Oldversion | Newversion
Eclipse 2021-06 (4.20) Eclipse 2022-06 (4.24)
2021-06 2022-06

Download https://www.eclipse.org/download https://www.eclipse.org/downloads
s/packages/release/2021-06/r /packages/release/2022-06/r

Installing Eclipse:

e Extract distribution archiveinanydirectory: at Esisar in /opt/Eclipse

workspace-empty - Eclipse IDE A _D0Ox
File Ecit Navigate Search Project Run Window Help

o P Y S Y A a:im g s

About Eclipse IDE A O X
\ @
g clipse IDE for Enterprise Java and Web Developers (includes Incubating components) E i
&5 Project Exp] |4 A Version: 2022-06 (4.24.0) -0
# Build id: 20220609-1112 B ditor that

/| (¢) Copyright Eclipse contributors and others 2000, 2022. All rights reserved. Eclipse and the Eclipse
0go are trademarks of the Eclipse Foundation, Inc., https:/www.eclipse.org/. The Eclipse logo cannot be
Itered without Eclipses permission. Eclipse logos are provided for use under the Eclipse logo and

4 trademark guidelines, https://www.eclipse.org/logotm/. Oracle and Java are trademarks or registered

W tredemarks of Oracle andor its affiliates. Other names may be trademarks of their respective owners.

There are no
workspace.
To add a projq

product includes software developed by other open source projects including the Apache Software
@ Create a| oundation, https://www.apache.org/.

EICE Y090 EOAMES -B ¢
i lmport pf @ istallation Details

[E Markers x [ Properties % Servers [ Data Source Explorer [ Snippets (& Terminal Y & = B

Configuring Eclipseto use the OpenJDK:
e In Window > Preferences >Java > Installed JRE:
4 https://en.wikipedia.org/wiki/Eclipse_(software)
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L e Ecli

nc
& Prefi o x
File Edit Navigate Sea references -
b AT type filter text Installed JREs G ow e 8
R v Bl w o 2 O o General Add, remove or edit |RE definitions. By default, the checked JRE is added to the
Ant
Add JRE A O X
[{5 Project Explorer x Dat E N !
. Grad RE Definition
Holy  Specify attributes for a JRE
There are no projects in yol |
nst;
workspace.
To add a project: Java |RE home: Jusrflibfjym/java-1.11.0-openjdk-amd64 Directory.
o A
Create a Maven projed g JRE name: java-11-openjdk-amd6d
(& Create a Java FE FAR |
(% Create a Dynamic Wel a Default VM arguments: Variables...
. q
& Create an E|B project g [RE system libraries: 0.
B p |+ & fustlibfjvmfjava-1.11.0-openjdk-amda/libfrt-fs. jar Add External JARS
Create a Java EE applit X |
w client project E
54 Create a generic depld b I
@9 web project. J
& Create a |PA project P
% Create a project.. Java
g Import projects... Java
Lan
Mawv
Oon
Plug
Run,
Sery Restore Default
Tern
Vali »
0 items selacted VersTonmcontror (Teant

ditor that

Type

In Window > Preferences > Java > Compiler:

type filter text

» General
» Ant
p Data Management
) Gradle
) Help
» Install/Update
- Java
} Appearance
p Build Path
Code Coverage
} Code Style
» Debug
p Editor
b Installed JREs
JUnit
Properties Files Edit
p Java EE
} Java Persistence
» Language Servers
» Maven
» Oomph
» Plug-in Development
» Run/Debug
p Server
» Terminal
) TextMate
Validation
p Version Control (Team

Qs ®

Preferences A O

v §

Configure Project Specific Settings...

Compiler G w o

JDK Compliance

Compiler compliance level: 11 -
Use '--release’ option
Use default compliance settings
Enable preview features for Java 18
Preview features with severity level: Warning -
Generated .class files compatibility: 11 -
Source compatibility: 11 -
Disallow identifiers called 'assert": g Error -
Disallow identifiers called '‘enum’: Error -

Classfile Generation
Add variable attributes to generated class files (used by the debugger)
Add line number attributes to generated class files (used by the debugger)
Add source file name to generated class file (used by the debugger)
Preserve unused (never read) local variables
nline finally blocks (larger class files, but improved performance)
Store information about method parameters (usable via reflection)

Restore Defaults Apply

Cancel Apply and
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Configuring Eclipse with Apache Maven:

In Window > Preferences > Maven > Installations:

AEeh Edit Maven Runtime

Specify attributes for a Maven installation

Installation type: Q) External () Workspace
Installation home:  jopt/Maven/Maven-3.8.4

Installation name: Maven-3.8.4

Additional extension libraries:

)

Directory...

Project...

Remowve

Down

Restore Default

e In Window > Preferences > Maven > User Settings:

Maven fhome/chollets/.m2/repository

Archetypes
Discovery
Errors/Wamings
Installations
Java EE Integration
Lifecycle Mappings
Source Lookup
User Interface

Oomph

Plug-in Development

Run/Debug

Server

Terminal

TextMate

Validation

Version Control (Team

Web

Web Services

%10

:: Preferences A O X
type filter text User Settings page g
General .
ene Global Settings (open file):

Ant

Data Management Jopt/Maven/Maven-3.8.4/conf/settings.xml Browse
Gradle User Settings:

Help fhome/chollets/.m2/settings.xml Browse
Install/Update

Java Update Settings

Java EE

Java Persistence

Local Repository (From merged user and global settings):
Language Servers

Reindex

Restore Defaults Apply

Cance Apply and Close
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3. New software

3.1. Node.js: Runtime environment

“Node.jsisan open-source, cross-platform, back-end JavaScript runtime environment that runs
on a JavaScript Engine (i.e. V8 engine) and executes JavaScript code outside a web browser,
which was designed to build scalable network applications.””

12205
2021-08-11

Download https://nodejs.org/en/download/releases/
Node.js website: https://nodejs.org/en/

Testinginstallation:

$ node -v

v12.22.5

3.2. npm: Build automation tool

“npm (originally short for Node Package Manager)[4] is a package manager for the JavaScript
programming language maintained by npm, Inc. npm is the default package manager for the
JavaScript runtime environment Node.js. It consists of a command line client, al so called npm,
and an online database of public and paid-for private packages, called the npm registry. The
registry is accessed via the client, and the available packages can be browsed and searched via
the npm website. The package manager and the registry are managed by npm, Inc.”®

752
2022-02-02

Download https://nodejs.org/download/release/v15.8.0/
npm website: https://www.npmjs.com/

Testinginstallation:

$ npm -v

7.5.2

> https://en.wikipedia.org/wiki/Node.js
6 https://en.wikipedia.org/wiki/Npm_(software)
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3.3. Sonatype Nexus Repository: Repository Management

npm registries were added in Sonatype Nexus Repository. Figure 3is a screenshot of the Sonatype
Nexus Repository configuration for Grenoble INP —Esisar. This configuration is similar to the Apache

Maven configuration.

Configuration of npm:

To use nexus repository manager with npm, it is required to configure npm to check the
repository managerinstead of the default, built-in connection to the Central repository. To do this,
we added configuration in the file /etc/nprmc:

registry = http://nexus.esisar.grenoble-inp.fr:8081/repository/npm/

Andalsoin thefile /etc/bash.bashrc:

export no_proxy=nexus.esisar.grenoble-inp.fr

3.4. Visual Studio Code: Integrated Development Environment

“Visual Studio Code, also commonly referred to as VS Code, is a source-code editor made by
Microsoft for Windows, Linux and macOS. Features include support for debugging, syntax
highlighting, intelligent code completion, snippets, code refactoring, and embedded Git. Users
can change the theme, keyboard shortcuts, preferences, and install extensions that add

additional functionality.”’

1.65.0

20220
https://code.visualstudio.com/updates/vl 65

Visual Studio Code website: https://code.visualstudio.com/

7 https://en.wikipedia.org/wiki/Visual Studio_Code
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Visual Studio Code

Visual Studio Code

Version: 1.65.0

Commit: b5205cc8ebdfbaa726835538cd82372cc0222d43
Date: 2022-03-02T11:12:36.2482 (6 mos ago)

Electron: 13.5.2

Chromium: 91.0.4472.164

Node.js: 14.16.0

V8: 9.1.269.39-electron.0

05: Linux x64 5.10.0-15-amd64

Copy @Valider

At Grenoble INP —Esisar, we added the Vetur plugintofacilitate the development of Vue.js code.
Veturpluginisan extension forVisual Studio Code available from the Visual Studio marketplace:
https://marketplace.visualstudio.com/items?itemName=octref.vetur

ﬂ Get Started - Visual Studio Code A~ O X

File Edit Selection View Go Run Terminal Help

) Get Started X

~ INSTALLED Get Started with VS Code

Vetur Discover the be

Choose the look you want

u]
E:' > POPULAR

~ RECOMMENDED Browse Color Themes
Vim shortcut (Ctri+K Ctri+T)
Vim emulation fi

vscodevim _ .
Sync to and from other devices

I =l
mrcrowl

GitLens ...

GitKraken Install ~
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“PostgreSQL also known as Postgres, is a free and open-source relational database management
system (RDBMS) emphasizing extensibility and SQL compliance. It was originally named
POSTGRES, referring to its origins as a successor to the Ingres database developed at the
University of California, Berkeley. In 1996, the project was renamed to PostgreSQL to reflect its
support for SQL. After a review in 2007, the development team decided to keep the name
PostgreSQL and the alias Postgres.”®

3.5. PostgreSQL: relational database

57
2022.05.0
https://www.postgresgl.org/ftp/source/v13.7/

PostgreSQL website: https://www.postgresgl.org/

Server URL at Grenoble INP —Esisar : http://postgres.esisar.grenoble-inp.fr

8 https://en.wikipedia.org/wiki/PostgreSQL
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